Update radio support in demo application
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
index 11e85ec..89e3c4e 100644 (file)
@@ -8,21 +8,27 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
     qtbase \
+    qtbase-native \
     qtdeclarative \
+    qtwebsockets \
     glib-2.0 \
     bluez-glib \
     connman-glib \
     libmpdclient \
+    protobuf-native \
+    grpc-native \
+    protobuf \
+    grpc \
 "
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "1332cc7d0a618ee88b4d19813340665332d406ca"
+SRCREV  = "9a7e2c5420cae0669c149d5dddbcd99a8fac0038"
 S       = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "2.0+git${SRCPV}"
 
-inherit cmake_qt5 pkgconfig
+inherit meson pkgconfig
 
 RRECOMMENDS:${PN} += "bluez5 connman mpd"