libqtappfw: Add Bluetooth media control support
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
index 3b99ef1..11e85ec 100644 (file)
@@ -6,10 +6,17 @@ SECTION     = "libs"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib"
+DEPENDS = " \
+    qtbase \
+    qtdeclarative \
+    glib-2.0 \
+    bluez-glib \
+    connman-glib \
+    libmpdclient \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "0fee9bfb0f656b78f34c44542329760be2980892"
+SRCREV  = "1332cc7d0a618ee88b4d19813340665332d406ca"
 S       = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
@@ -17,4 +24,6 @@ PV = "2.0+git${SRCPV}"
 
 inherit cmake_qt5 pkgconfig
 
+RRECOMMENDS:${PN} += "bluez5 connman mpd"
+
 BBCLASSEXTEND = "nativesdk"