Remove usage of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / launcher / launcher_git.bb
index 3637070..431c96a 100644 (file)
@@ -10,22 +10,38 @@ DEPENDS = "\
         qtdeclarative \
         qtquickcontrols2 \
         qtwebsockets \
-        qlibhomescreen \
         wayland-native \
         wayland \
         qtwayland \
         qtwayland-native \
+        agl-compositor \
+        json-c \
+        applaunchd \
 "
 
 PV      = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = " \
+        git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
+        file://launcher.service \
+        "
+SRCREV  = "21a1fef41137a1dffc6ff0a602665999a7f6cc66"
 
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig aglwgt
+inherit qmake5 systemd pkgconfig
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
-RDEPENDS_${PN} = "agl-service-homescreen"
+do_install:append() {
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
+    ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+}
+
+FILES:${PN} += " ${systemd_user_unitdir}"
+
+RDEPENDS:${PN} += " \
+    applaunchd \
+    homescreen \
+"