Refresh HTML5 demo apps design.
[AGL/meta-agl-demo.git] / recipes-demo / html5-launcher / html5-launcher_git.bb
index ecafd19..a50c175 100644 (file)
@@ -9,13 +9,19 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
-  file://launcher.desktop \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
 "
-SRCREV = "b37179742fac1053ba621cfa12938ec6536cf1f7"
+SRCREV = "ccdd59db7dc073eee0a35d0318640d9833824073"
+
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "launcher"
+AGL_APP_NAME = "HTML5 Launcher"
 
 DEPENDS = "nodejs-native"
 
+do_compile[network] = "1"
 do_compile() {
   cd ${S}
   rm -rf package node_modules package-lock.json
@@ -23,20 +29,14 @@ do_compile() {
   npm run build
 }
 
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
 
 do_install() {
   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-  install -d ${D}${APPLICATIONS_DIR}
-  install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
 }
 
-FILES_${PN} = " \
-  ${WAM_APPLICATIONS_DIR}/${PN} \
-  ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
 
-RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd"
+RCONFLICTS:${PN} = "launcher flutter-homescreen"
+RDEPENDS:${PN} = "applaunchd"