meta-agl-demo: use HTML5 homescreen+background+launcher in HTML5 demo
[AGL/meta-agl-demo.git] / recipes-demo / html5-launcher / html5-launcher_git.bb
index 2a4f7ed..61899e4 100644 (file)
@@ -10,7 +10,7 @@ B       = "${WORKDIR}/build"
 
 SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
-  file://launcher.service \
+  file://launcher.desktop \
 "
 SRCREV = "${AGL_APP_REVISION}"
 
@@ -23,18 +23,19 @@ do_compile() {
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
 
 do_install() {
   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-  install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-  install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
-  ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
 }
 
 FILES_${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
-  ${systemd_user_unitdir} \
+  ${APPLICATIONS_DIR} \
 "
 
 RCONFLICTS_${PN} = "launcher"
+RDEPENDS_${PN} = "applaunchd"
\ No newline at end of file