chromium, html5-*: adapt to kirkstone
[AGL/meta-agl-demo.git] / recipes-demo / html5-launcher / html5-launcher_git.bb
index 61899e4..5908700 100644 (file)
@@ -1,4 +1,4 @@
-SUMMARY     = "AGL HTML5 HVAC Application"
+SUMMARY     = "AGL HTML5 Launcher Application"
 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-launcher/"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
@@ -9,17 +9,20 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
   file://launcher.desktop \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "1283e3bddd4655be0d5208fbbcd9535f8f1ff0f6"
+
+inherit pythonnative
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -32,10 +35,10 @@ do_install() {
   install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
 }
 
-FILES_${PN} = " \
+FILES:${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
   ${APPLICATIONS_DIR} \
 "
 
-RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd"
\ No newline at end of file
+RCONFLICTS:${PN} = "launcher"
+RDEPENDS:${PN} = "applaunchd"