chromium, html5-*: adapt to kirkstone
[AGL/meta-agl-demo.git] / recipes-demo / html5-launcher / html5-launcher_git.bb
index 2a4f7ed..5908700 100644 (file)
@@ -1,4 +1,4 @@
-SUMMARY     = "AGL HTML5 HVAC Application"
+SUMMARY     = "AGL HTML5 Launcher Application"
 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-launcher/"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
@@ -9,32 +9,36 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
-  file://launcher.service \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
+  file://launcher.desktop \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "1283e3bddd4655be0d5208fbbcd9535f8f1ff0f6"
+
+inherit pythonnative
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
 
 do_install() {
   install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
   cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-  install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-  install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
-  ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
 }
 
-FILES_${PN} = " \
+FILES:${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
-  ${systemd_user_unitdir} \
+  ${APPLICATIONS_DIR} \
 "
 
-RCONFLICTS_${PN} = "launcher"
+RCONFLICTS:${PN} = "launcher"
+RDEPENDS:${PN} = "applaunchd"