wam, chromium, html5-*: improve initial frame, and drop usage of config.xml
[AGL/meta-agl-demo.git] / recipes-demo / html5-launcher / html5-launcher_git.bb
index 61899e4..52d7077 100644 (file)
@@ -1,4 +1,4 @@
-SUMMARY     = "AGL HTML5 HVAC Application"
+SUMMARY     = "AGL HTML5 Launcher Application"
 HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-launcher/"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
@@ -9,17 +9,18 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
   file://launcher.desktop \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "cb6b66c3bd94a6ab18cad3ad87c827d4f7e623e9"
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
 "
 
 RCONFLICTS_${PN} = "launcher"
-RDEPENDS_${PN} = "applaunchd"
\ No newline at end of file
+RDEPENDS_${PN} = "applaunchd"