Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-demo / html5-homescreen / html5-homescreen_git.bb
index 567d1d6..18ffea5 100644 (file)
@@ -14,7 +14,7 @@ PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
-inherit pythonnative systemd
+inherit systemd
 
 DEPENDS = "nodejs-native"
 
@@ -33,7 +33,7 @@ SYSTEMD_SERVICE:${PN} = "homescreen.service"
 do_install() {
     install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
     cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-    install -D -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+    install -D -m 0644 ${UNPACKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
 }
 
 FILES:${PN} = " \