wam, chromium, html5-*: improve initial frame, and drop usage of config.xml
[AGL/meta-agl-demo.git] / recipes-demo / html5-homescreen / html5-homescreen_git.bb
index 1d5f14a..058e921 100644 (file)
@@ -9,17 +9,18 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
   file://homescreen.service \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "5c9e060c508ab5ea49241d3a88f86075d6dc39cf"
 
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -38,4 +39,4 @@ FILES_${PN} = " \
 "
 
 RCONFLICTS_${PN} = "homescreen"
-RDEPENDS_${PN} = "applaunchd html5-background"
\ No newline at end of file
+RDEPENDS_${PN} = "applaunchd html5-background"