meta-agl-demo: use HTML5 homescreen+background+launcher in HTML5 demo
[AGL/meta-agl-demo.git] / recipes-demo / html5-background / html5-background_git.bb
index c0ac220..cf1dee1 100644 (file)
@@ -1,13 +1,40 @@
-SUMMARY     = "AGL HTML5 Background Application"
+SUMMARY     = "AGL HTML5 Homescreen"
+HOMEPAGE    = "https://github.com/AGL-web-applications/background"
+SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
+B       = "${WORKDIR}/build"
 
-SRC_URI = "git://github.com/AGL-web-applications/background.git;protocol=https;branch=master"
+SRC_URI = " \
+  git://github.com/AGL-web-applications/background.git;protocol=https;branch=master \
+  file://webapps-html5-background.desktop \
+"
 SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
 
 DEPENDS = "nodejs-native"
 
-inherit aglwgt
+do_compile() {
+  bldcmd=${S}/autobuild/agl/autobuild
+  cd ${S}
+  $bldcmd build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+  install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+  install -d ${D}${APPLICATIONS_DIR}
+  install ${WORKDIR}/webapps-html5-background.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES_${PN} = " \
+  ${WAM_APPLICATIONS_DIR}/${PN} \
+  ${APPLICATIONS_DIR} \
+"
+
+RCONFLICTS_${PN} = "homescreen"