Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index bfdf06e..bf8034b 100644 (file)
@@ -1,37 +1,43 @@
-SUMMARY     = "AGL Home Screen Application"
-DESCRIPTION = "AGL Home Screen Application build with recipe method"
+SUMMARY     = "Home Screen application"
+DESCRIPTION = "AGL demonstration Home Screen application"
 HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "\
-        qtbase \
-        qtdeclarative \
-        qtquickcontrols2 \
-        agl-service-homescreen \
-        agl-service-weather \
-        libqtappfw \
-        libhomescreen \
-        libafb-helpers-qt \
-        wayland-native \
-        wayland \
-        qtwayland \
-        qtwayland-native \
+DEPENDS = " \
+    qtbase \
+    qtdeclarative \
+    qtquickcontrols2 \
+    libqtappfw \
+    libhomescreen \
+    libafb-helpers-qt \
+    wayland-native \
+    wayland \
+    qtwayland \
+    qtwayland-native \
+    agl-compositor \
 "
 
-inherit qmake5 systemd pkgconfig aglwgt
+PV      = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
+
+inherit qmake5 systemd pkgconfig aglwgt
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
-OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-RDEPENDS_${PN} += " \
-        libqtappfw \
+RDEPENDS:${PN} += " \
+    libqtappfw \
+    agl-service-audiomixer \
+    agl-service-bluetooth \
+    agl-service-homescreen \
+    agl-service-network \
+    agl-service-weather \
+    agl-service-voice-high \
 "