Switch Qt demo to KUKSA.val databroker
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index 2b183d5..3d1ffb5 100644 (file)
@@ -9,36 +9,52 @@ DEPENDS = " \
     qtbase \
     qtdeclarative \
     qtquickcontrols2 \
+    libqtappfw \
     wayland-native \
     wayland \
     qtwayland \
     qtwayland-native \
     agl-compositor \
+    applaunchd \
 "
 
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
            file://homescreen.service \
+           file://homescreen.conf \
+           file://homescreen.token \
 "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "f32f949b3bd39eaebba71812b6bb2cb80d6ff90a"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig
+inherit meson pkgconfig systemd
 
 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
 do_install:append() {
-    install -D -p -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+    install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+    install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
 }
 
-SYSTEMD_SERVICE_${PN} = "homescreen.service"
-SYSTEMD_AUTO_ENABLE = "enable"
-
 RDEPENDS:${PN} += " \
+    libqtappfw \
+    applaunchd \
     qtwayland \
     qtbase-qmlplugins \
     qtgraphicaleffects-qmlplugins \