web-runtime: Add wam to agl-demo-platform-html5 image
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index 0347caf..2b183d5 100644 (file)
@@ -9,9 +9,6 @@ DEPENDS = " \
     qtbase \
     qtdeclarative \
     qtquickcontrols2 \
-    libqtappfw \
-    libhomescreen \
-    libafb-helpers-qt \
     wayland-native \
     wayland \
     qtwayland \
@@ -19,25 +16,30 @@ DEPENDS = " \
     agl-compositor \
 "
 
-PV      = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://homescreen.service \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
 
-S       = "${WORKDIR}/git"
+inherit qmake5 systemd pkgconfig
 
-inherit qmake5 systemd pkgconfig aglwgt
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+do_install:append() {
+    install -D -p -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+}
 
-RDEPENDS_${PN} += " \
-    libqtappfw \
-    agl-service-audiomixer \
-    agl-service-bluetooth \
-    agl-service-homescreen \
-    agl-service-network \
-    agl-service-weather \
-    agl-service-voice-high \
+SYSTEMD_SERVICE_${PN} = "homescreen.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
 "