homescreen_git.bb: Bump SRCREV to pick up compositor update
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index d21711c..1f8e0c7 100644 (file)
@@ -14,6 +14,8 @@ DEPENDS = " \
     wayland \
     qtwayland \
     qtwayland-native \
+    protobuf \
+    grpc grpc-native \
     agl-compositor \
     applaunchd \
 "
@@ -22,25 +24,36 @@ PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
            file://homescreen.service \
+           file://homescreen.conf \
+           file://homescreen.token \
 "
-SRCREV = "c35327b02a28a83536450a664326d183662e89e1"
+SRCREV = "2c91ad7b3b125176b2e26b435705557a089604a0"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig
+inherit meson pkgconfig systemd
 
 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
 do_install:append() {
-    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-    install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
-    ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+    install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+    install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
 }
 
-FILES:${PN} += " ${systemd_user_unitdir}"
-
 RDEPENDS:${PN} += " \
     libqtappfw \
     applaunchd \