homescreen_git.bb: Bump SRCREV to pick up compositor update
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index b53519e..1f8e0c7 100644 (file)
@@ -4,38 +4,60 @@ HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-#LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 DEPENDS = " \
     qtbase \
     qtdeclarative \
     qtquickcontrols2 \
+    libqtappfw \
     wayland-native \
     wayland \
     qtwayland \
     qtwayland-native \
+    protobuf \
+    grpc grpc-native \
     agl-compositor \
-    json-c \
-    qtwebsockets \
+    applaunchd \
 "
 
-PV      = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;nobranch=1"
-SRCREV  = "09b5eb1b42910e84612a37a0fb44629c73eee3e7"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://homescreen.service \
+           file://homescreen.conf \
+           file://homescreen.token \
+"
+SRCREV = "2c91ad7b3b125176b2e26b435705557a089604a0"
 
-S       = "${WORKDIR}/git"
+S = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig
+inherit meson pkgconfig systemd
 
 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
 
 do_install:append() {
-
-    install -d ${D}/${bindir}
-    install -m 0644 ${B}/homescreen/HomeScreen ${D}/${bindir}/homescreen
-
-}
\ No newline at end of file
+    install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+    install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
+}
+
+RDEPENDS:${PN} += " \
+    libqtappfw \
+    applaunchd \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+"