homescreen_git.bb: Bump SRCREV to pick up compositor update
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index 39e55ea..1f8e0c7 100644 (file)
@@ -14,6 +14,8 @@ DEPENDS = " \
     wayland \
     qtwayland \
     qtwayland-native \
+    protobuf \
+    grpc grpc-native \
     agl-compositor \
     applaunchd \
 "
@@ -25,20 +27,20 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=http
            file://homescreen.conf \
            file://homescreen.token \
 "
-SRCREV = "20f629dd6d8628611d950073c4f7a0446c40365a"
+SRCREV = "2c91ad7b3b125176b2e26b435705557a089604a0"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig
+inherit meson pkgconfig systemd
 
 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
 do_install:append() {
-    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-    install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
-    ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+    install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
 
     # Currently using default global client and CA certificates
     # for KUKSA.val SSL, installing app specific ones would go here.
@@ -52,8 +54,6 @@ do_install:append() {
     install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
 }
 
-FILES:${PN} += " ${systemd_user_unitdir}"
-
 RDEPENDS:${PN} += " \
     libqtappfw \
     applaunchd \