homescreen_git.bb: Bump SRCREV to pick up compositor update
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index 1ec938b..1f8e0c7 100644 (file)
@@ -10,33 +10,54 @@ DEPENDS = " \
     qtdeclarative \
     qtquickcontrols2 \
     libqtappfw \
-    libhomescreen \
-    libafb-helpers-qt \
     wayland-native \
     wayland \
     qtwayland \
     qtwayland-native \
+    protobuf \
+    grpc grpc-native \
+    agl-compositor \
+    applaunchd \
 "
 
-PV      = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://homescreen.service \
+           file://homescreen.conf \
+           file://homescreen.token \
+"
+SRCREV = "2c91ad7b3b125176b2e26b435705557a089604a0"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig systemd
 
-S       = "${WORKDIR}/git"
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
-inherit qmake5 systemd pkgconfig aglwgt
+OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
 
-OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+do_install:append() {
+    install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
 
-RDEPENDS_${PN} += " \
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+    install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
+}
+
+RDEPENDS:${PN} += " \
     libqtappfw \
-    agl-service-audiomixer \
-    agl-service-bluetooth \
-    agl-service-homescreen \
-    agl-service-network \
-    agl-service-weather \
-    agl-service-voice-high \
+    applaunchd \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
 "