homescreen: update recipe
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
index b53519e..2b183d5 100644 (file)
@@ -4,7 +4,6 @@ HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-#LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 DEPENDS = " \
     qtbase \
@@ -15,16 +14,16 @@ DEPENDS = " \
     qtwayland \
     qtwayland-native \
     agl-compositor \
-    json-c \
-    qtwebsockets \
 "
 
-PV      = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;nobranch=1"
-SRCREV  = "09b5eb1b42910e84612a37a0fb44629c73eee3e7"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://homescreen.service \
+"
+SRCREV = "${AGL_APP_REVISION}"
 
-S       = "${WORKDIR}/git"
+S = "${WORKDIR}/git"
 
 inherit qmake5 systemd pkgconfig
 
@@ -32,10 +31,15 @@ PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-
 do_install:append() {
+    install -D -p -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+}
 
-    install -d ${D}/${bindir}
-    install -m 0644 ${B}/homescreen/HomeScreen ${D}/${bindir}/homescreen
+SYSTEMD_SERVICE_${PN} = "homescreen.service"
+SYSTEMD_AUTO_ENABLE = "enable"
 
-}
\ No newline at end of file
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+"