Updates for KUKSA.val 0.2.5
[AGL/meta-agl-demo.git] / recipes-demo / dashboard / dashboard_git.bb
index 70a8793..fe09bbd 100644 (file)
@@ -1,23 +1,47 @@
-SUMMARY     = "Dashboard for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI Application for demonstrating dashboard on AGL Distribution"
+SUMMARY     = "Dashboard application"
+DESCRIPTION = "AGL demonstration Dashboard application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/dashboard"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0"
+LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = " \
+    qttools-native \
+    qtquickcontrols2 \
+    libqtappfw \
+"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH} \
+           file://dashboard.conf \
+           file://dashboard.token \
+"
+SRCREV  = "ba638ce33cfac78b07c8fb69947bf6aead57d6b7"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig agl-app
 
-PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
+AGL_APP_NAME = "Dashboard"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native libqtappfw"
+do_install:append() {
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
 
-inherit qmake5 aglwgt
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/dashboard
+    install -m 0644 ${WORKDIR}/dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
+}
 
-RDEPENDS_${PN} += " \
-       libqtappfw \
-       agl-service-signal-composer \
+RDEPENDS:${PN} += " \
+    qtwayland \
+    qtbase-qmlplugins \
+    qtgraphicaleffects-qmlplugins \
+    qtquickcontrols2-agl-style \
 "