Update github.com git:// SRC_URIs
[AGL/meta-agl-demo.git] / recipes-demo / dashboard / dashboard_git.bb
index 70a8793..22f5b73 100644 (file)
@@ -1,23 +1,23 @@
-SUMMARY     = "Dashboard for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI Application for demonstrating dashboard on AGL Distribution"
+SUMMARY     = "Dashboard application"
+DESCRIPTION = "AGL demonstration Dashboard application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/dashboard"
 SECTION     = "apps"
 
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = "qtquickcontrols2 qttools-native libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native libqtappfw"
-
 inherit qmake5 aglwgt
 
-RDEPENDS_${PN} += " \
-       libqtappfw \
-       agl-service-signal-composer \
+RDEPENDS:${PN} += " \
+    libqtappfw \
+    agl-service-signal-composer \
 "