Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / cluster-receiver_git.bb
index a341ef2..fd41e08 100644 (file)
@@ -6,20 +6,22 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0 & MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = " \
+    wayland wayland-native \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
+"
 
 PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "wayland wayland-native \
-           gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+S  = "${WORKDIR}/git"
 
 inherit cmake pkgconfig aglwgt
 
-RDEPENDS_${PN} += " \
-       gstreamer1.0-plugins-base \
-       gstreamer1.0-plugins-good \
-       gstreamer1.0-plugins-bad \
+RDEPENDS:${PN} += " \
+    gstreamer1.0-plugins-base \
+    gstreamer1.0-plugins-good \
+    gstreamer1.0-plugins-bad \
 "