cluster-receiver: update SRCREV
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / cluster-receiver_git.bb
index 7028d5f..605d111 100644 (file)
@@ -1,5 +1,5 @@
-SUMMARY     = "Instrument Cluster Receiver application"
-DESCRIPTION = "AGL demonstration instrument cluster remote display application"
+SUMMARY     = "Instrument Cluster receiver application"
+DESCRIPTION = "AGL demonstration instrument cluster XDG remote display application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
 SECTION     = "apps"
 
@@ -8,17 +8,26 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
 
 DEPENDS = " \
     wayland wayland-native \
-    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad agl-compositor \
+    agl-compositor \
+    gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
 "
 
 PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH} \
+           file://cluster-receiver.service \
+"
+SRCREV  = "6ac9d958963cc26b1fd435854e12b03f87127a23"
 
 S  = "${WORKDIR}/git"
 
-inherit cmake pkgconfig aglwgt
+inherit cmake pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
+
+do_install:append() {
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+}
 
 RDEPENDS:${PN} += " \
     gstreamer1.0-plugins-base \