Flutter bbclass refactor
[AGL/meta-agl-demo.git] / recipes-demo / camera-gstreamer / camera-gstreamer_git.bb
index f08e410..fabfaa2 100644 (file)
@@ -14,13 +14,15 @@ DEPENDS = " \
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/camera-gstreamer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "30c275c5c87b9d4f0bc3b0e0e3175775d3738319"
 
 S  = "${WORKDIR}/git"
 
-inherit cmake pkgconfig aglwgt
+inherit cmake pkgconfig agl-app
 
-RDEPENDS_${PN} += " \
+AGL_APP_NAME = "Camera"
+
+RDEPENDS:${PN} += " \
     gstreamer1.0-plugins-base \
     gstreamer1.0-plugins-good \
     gstreamer1.0-plugins-bad \