Bump camera for picking latest changes
[AGL/meta-agl-demo.git] / recipes-demo / camera-gstreamer / camera-gstreamer_git.bb
index f08e410..0447ea5 100644 (file)
@@ -7,20 +7,22 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
-    wayland wayland-native \
+    wayland wayland-native grpc grpc-native \
     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
 "
 
 PV = "1.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/camera-gstreamer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "a7b8d60c62554b4571e0155ce44794b123cf1c09"
 
 S  = "${WORKDIR}/git"
 
-inherit cmake pkgconfig aglwgt
+inherit meson pkgconfig agl-app
 
-RDEPENDS_${PN} += " \
+AGL_APP_NAME = "Camera"
+
+RDEPENDS:${PN} += " \
     gstreamer1.0-plugins-base \
     gstreamer1.0-plugins-good \
     gstreamer1.0-plugins-bad \