Update github.com git:// SRC_URIs
[AGL/meta-agl-demo.git] / recipes-demo / alexa-viewer / alexa-viewer_git.bb
index f73a97a..d8af688 100644 (file)
@@ -7,29 +7,32 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = " \
-       qtquickcontrols2 \
-       qlibhomescreen \
-       af-binder \
-       libqtappfw \
-       wayland-native \
-       wayland \
-       qtwayland \
-       qtwayland-native \
+    qtquickcontrols2 \
+    qlibhomescreen \
+    af-binder \
+    libqtappfw \
+    wayland-native \
+    wayland \
+    qtwayland \
+    qtwayland-native \
+    agl-compositor \
 "
 
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 inherit cmake_qt5 aglwgt
 
-OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+OECMAKE_CXX_FLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
 
-RDEPENDS_${PN} = " \
-       libqtappfw \
-       libafbwsc \
-       qlibhomescreen \
-       agl-service-voice-high-capabilities \
+RDEPENDS:${PN} = " \
+    libqtappfw \
+    libafbwsc \
+    qlibhomescreen \
+    agl-service-homescreen \
+    agl-service-voice-high-capabilities \
 "