Add gateway demo
[AGL/meta-agl-demo.git] / recipes-demo / agl-service-audiomixer / agl-service-audiomixer_git.bb
index 89595bb..a1f6f79 100644 (file)
@@ -2,21 +2,36 @@ SUMMARY     = "Audio Mixer Service Daemon"
 DESCRIPTION = "AGL Audio Mixer Service Daemon"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-audiomixer"
 SECTION     = "apps"
-LICENSE     = "MIT"
+LICENSE     = "MIT & Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
 
-DEPENDS = "boost openssl nlohmann-json systemd pipewire wireplumber"
+DEPENDS = " \
+    glib-2.0 \
+    boost \
+    openssl \
+    systemd \
+    pipewire \
+    wireplumber \
+    protobuf-native \
+    grpc-native \
+    protobuf \
+    grpc \
+    kuksa-databroker \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
-           file://agl-service-audiomixer.conf \
+           file://agl-service-audiomixer.conf.default \
+           file://agl-service-audiomixer.conf.gateway-demo \
            file://agl-service-audiomixer.token \
 "
-SRCREV  = "f137c6762e9055600089bb251850f979f62aed50"
+SRCREV  = "0ff3ef1b254364639fc42495bbcfb4760250990a"
 
 PV = "2.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-inherit meson pkgconfig systemd
+inherit meson pkgconfig systemd update-alternatives
+
+EXTRA_OEMESON += "-Dprotos=${STAGING_INCDIR}"
 
 SYSTEMD_SERVICE:${PN} = "agl-service-audiomixer.service" 
 
@@ -29,10 +44,28 @@ do_install:append() {
     # until a packaging/sandboxing/MAC scheme is (re)implemented or
     # something like OAuth is plumbed in as an alternative.
     install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
-    install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.default ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
     install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
 }
 
 FILES:${PN} += "${systemd_system_unitdir}"
 
-RDEPENDS:${PN} += "kuksa-val"
+RDEPENDS:${PN} += "${PN}-conf"
+
+ALTERNATIVE_LINK_NAME[agl-service-audiomixer.conf] = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf"
+
+PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-gateway-demo"
+
+FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.default"
+RDEPENDS:${PN}-conf = "${PN}"
+RPROVIDES:${PN}-conf = "agl-service-audiomixer.conf"
+ALTERNATIVE:${PN}-conf = "agl-service-audiomixer.conf"
+ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.default"
+
+FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.gateway-demo"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "agl-service-audiomixer.conf"
+ALTERNATIVE:${PN}-conf-gateway-demo = "agl-service-audiomixer.conf"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"