Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-core / psplash / psplash-portrait-config.bb
index 7afee44..8b32dc2 100644 (file)
@@ -6,13 +6,16 @@ inherit systemd allarch
 
 SRC_URI = "file://psplash-portrait.conf"
 
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
 do_configure[noexec] = "1"
 do_compile[noexec] = "1"
 
 do_install() {
     # Install override
     install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
-    install -m 0644 ${WORKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+    install -m 0644 ${UNPACKDIR}/psplash-portrait.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
 }
 
 FILES:${PN} += "${systemd_system_unitdir}"