Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-core / psplash / psplash-inverted-config.bb
index f11b255..0bc067c 100644 (file)
@@ -6,13 +6,16 @@ inherit systemd allarch
 
 SRC_URI = "file://psplash-inverted.conf"
 
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
 do_configure[noexec] = "1"
 do_compile[noexec] = "1"
 
 do_install() {
     # Install override
     install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
-    install -m 0644 ${WORKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
+    install -m 0644 ${UNPACKDIR}/psplash-inverted.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
 }
 
 FILES:${PN} += "${systemd_system_unitdir}"