Switch Qt demo to KUKSA.val databroker
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-dbc-feeder_git.bb
index 7d31118..809152b 100644 (file)
@@ -2,30 +2,29 @@ SUMMARY = "DBC feeder for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
 HOMEPAGE = "https://github.com/eclipse/kuksa.val"
 BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
 
-LICENSE = "EPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=175792518e4ac015ab6696d16c4f607e"
 
 DEPENDS = "python3-setuptools-git-versioning-native"
 
-require kuksa-val.inc
+PV = "0.4.0+git${SRCPV}"
 
-SRC_URI += "file://0001-dbc2val-add-installation-mechanism.patch \
-            file://0002-dbc2val-usability-improvements.patch \
-            file://config.ini \
-            file://dbc_feeder.json.token \
-            file://mapping.yml \
-            file://agl-vcar.dbc \
-            file://kuksa-dbc-feeder.service \
-"
+SRC_URI = "git://github.com/eclipse/kuksa.val.feeders.git;protocol=https;branch=main \
+           file://0001-dbc2val-add-installation-mechanism.patch \
+           file://0002-dbc2val-usability-improvements.patch \
+           file://0003-dbc2val-fix-token-file-configuration-option.patch \
+           file://config.ini \
+           file://dbc_feeder.token \
+           file://agl-vcar.dbc \
+           file://kuksa-dbc-feeder.service \
+           "
+SRCREV = "5bb52eca8d79f7c05a024f69b1faab81dabacdcd"
 
-inherit setuptools3 systemd
+S = "${WORKDIR}/git"
 
-SETUPTOOLS_SETUP_PATH = "${S}/kuksa_feeders"
+inherit setuptools3 systemd
 
-# This is a bit of a workaround as the sed in distutils.bbclass
-# will remove the -S already present in the script otherwise,
-# breaking it.
-PEP517_INSTALL_PYTHON = "-S python3 -u"
+SETUPTOOLS_SETUP_PATH = "${S}/dbc2val"
 
 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
 
@@ -35,8 +34,7 @@ do_install:append() {
     # Token should ideally not be readable by other users.
     # The potential for running the feeder as non-root will take some
     # investigation.
-    install -m 0600 ${WORKDIR}/dbc_feeder.json.token ${D}${sysconfdir}/kuksa-dbc-feeder/
-    install -m 0644 ${WORKDIR}/mapping.yml ${D}${sysconfdir}/kuksa-dbc-feeder/
+    install -m 0600 ${WORKDIR}/dbc_feeder.token ${D}${sysconfdir}/kuksa-dbc-feeder/
     install -m 0644 ${WORKDIR}/agl-vcar.dbc ${D}${sysconfdir}/kuksa-dbc-feeder/
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         install -d ${D}${systemd_system_unitdir}
@@ -54,6 +52,6 @@ RDEPENDS:${PN} += " \
     python3-can-j1939 \
     python3-pyyaml \
     python3-py-expression-eval \
-    kuksa-viss-client \
+    kuksa-client \
     can-dev-helper \
 "