Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-databroker_git.bb
index c35c6d9..72f8725 100644 (file)
@@ -13,14 +13,13 @@ require kuksa-val.inc
 
 require ${BPN}-crates.inc
 
-SRC_URI += "file://0001-Force-older-clap-version-to-build-with-Rust-1.68.patch \
-            file://0002-Remove-protobuf-src-usage.patch \
+SRC_URI += "file://0001-Remove-protobuf-src-usage.patch \
             file://kuksa-databroker.service \
 "
 
 S = "${WORKDIR}/git"
 
-inherit cargo systemd useradd
+inherit cargo cargo-update-recipe-crates systemd useradd
 
 # Enable optional VISS support for potential use by e.g. the web apps
 CARGO_BUILD_FLAGS += "--features viss"
@@ -35,7 +34,7 @@ USERADD_PARAM:${PN} = "--system -g 900 -u 900 -o -d / --shell /bin/nologin kuksa
 do_install:append() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         install -d ${D}${systemd_system_unitdir}
-        install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
+        install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
     fi
 
     # Install gRPC API protobuf files