Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-databroker_git.bb
index ac0df73..72f8725 100644 (file)
@@ -19,7 +19,10 @@ SRC_URI += "file://0001-Remove-protobuf-src-usage.patch \
 
 S = "${WORKDIR}/git"
 
-inherit cargo systemd useradd
+inherit cargo cargo-update-recipe-crates systemd useradd
+
+# Enable optional VISS support for potential use by e.g. the web apps
+CARGO_BUILD_FLAGS += "--features viss"
 
 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
 
@@ -31,7 +34,7 @@ USERADD_PARAM:${PN} = "--system -g 900 -u 900 -o -d / --shell /bin/nologin kuksa
 do_install:append() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         install -d ${D}${systemd_system_unitdir}
-        install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
+        install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
     fi
 
     # Install gRPC API protobuf files