kuksa-databroker: update for building with Rust 1.70
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-databroker_git.bb
index ac0df73..2009c22 100644 (file)
@@ -19,7 +19,10 @@ SRC_URI += "file://0001-Remove-protobuf-src-usage.patch \
 
 S = "${WORKDIR}/git"
 
-inherit cargo systemd useradd
+inherit cargo cargo-update-recipe-crates systemd useradd
+
+# Enable optional VISS support for potential use by e.g. the web apps
+CARGO_BUILD_FLAGS += "--features viss"
 
 SYSTEMD_SERVICE:${PN} = "${BPN}.service"