Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / can-dev-helper_1.0.bb
index 90f5ff1..ae99006 100644 (file)
@@ -6,6 +6,9 @@ SRC_URI = "file://can-dev-helper.service \
            file://can-dev-helper.sh \
 "
 
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
 inherit systemd allarch
 
 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -14,8 +17,8 @@ do_configure[noexec] = "1"
 do_compile[noexec] = "1"
 
 do_install() {
-    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
-    install -D -m 0755 ${WORKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
+    install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+    install -D -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
 }
 
 FILES:${PN} += "${systemd_system_unitdir}"