Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-config / qemu-config / qemu-config-agl-cluster-demo-qt.bb
index e22e402..c6681c2 100644 (file)
@@ -6,6 +6,9 @@ inherit systemd allarch
 
 SRC_URI = "file://${QEMU_IMAGE}.conf"
 
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
 do_configure[noexec] = "1"
 do_compile[noexec] = "1"
 
@@ -21,7 +24,7 @@ do_install() {
 
     # Install conf file
     install -d ${D}${sysconfdir}/agl-qemu-runner
-    install -m 0644 ${WORKDIR}/${QEMU_IMAGE}.conf ${D}${sysconfdir}/agl-qemu-runner/
+    install -m 0644 ${UNPACKDIR}/${QEMU_IMAGE}.conf ${D}${sysconfdir}/agl-qemu-runner/
 }
 
 FILES:${PN} += "${systemd_system_unitdir}"