Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-config / cluster-demo-network-config / cluster-demo-network-config_1.0.bb
index 8d73728..12dcea7 100644 (file)
@@ -9,6 +9,9 @@ SRC_URI = "file://cluster-demo-network-conf@.service \
            file://cluster-demo-network-conf.sh \
 "
 
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
 # Network device for dedicated connection to cluster
 AGL_CLUSTER_NET_DEVICE ?= "eth1"
 
@@ -18,11 +21,11 @@ do_compile[noexec] = "1"
 do_install() {
     # Install helper script
     install -d ${D}${sbindir}
-    install -m 0755 ${WORKDIR}/cluster-demo-network-conf.sh ${D}${sbindir}/
+    install -m 0755 ${UNPACKDIR}/cluster-demo-network-conf.sh ${D}${sbindir}/
 
     # Install service unit
     install -d ${D}${systemd_system_unitdir}
-    install -m 0644 ${WORKDIR}/cluster-demo-network-conf@.service ${D}${systemd_system_unitdir}/
+    install -m 0644 ${UNPACKDIR}/cluster-demo-network-conf@.service ${D}${systemd_system_unitdir}/
 
     # Add symlink to network.target.wants
     install -d ${D}${sysconfdir}/systemd/system/network.target.wants