Build and install AMB-Qt plugins for QML
[AGL/meta-agl-demo.git] / recipes-automotive / automotive-message-broker / automotive-message-broker_git.bbappend
diff --git a/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend b/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bbappend
new file mode 100644 (file)
index 0000000..5a60105
--- /dev/null
@@ -0,0 +1,16 @@
+inherit cmake_qt5
+
+PACKAGECONFIG ??= "qmlplugins"
+
+PACKAGECONFIG[qmlplugins] = "-Dqt_bindings=On,,qtdeclarative"
+
+INSANE_SKIP_${PN} = "dev-deps"
+
+FILES_${PN} += " \
+    ${OE_QMAKE_PATH_QML}/amb/qmldir \
+    ${OE_QMAKE_PATH_QML}/amb/libambqtquick.so \
+"
+
+FILES_${PN}-dbg += " \
+    ${OE_QMAKE_PATH_QML}/amb/.debug/libambqtquick.so \
+"