Add a QML plugin to expose AMB's ClimateControl objects.
[AGL/meta-agl-demo.git] / recipes-automotive / ambdbusaccess / ambdbusaccess_0.1.bb
diff --git a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
new file mode 100644 (file)
index 0000000..c54e28c
--- /dev/null
@@ -0,0 +1,26 @@
+SUMMARY = "ambdbusaccess"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad \
+                    file://ambdbusaccess.cpp;startline=1;endline=5;md5=0ba6897a99e9332dae1891b4ccf78de3 \
+                   "
+
+SRC_URI = "file://* \
+          "
+S = "${WORKDIR}"
+
+DEPENDS = "qtdeclarative qtbase"
+RDEPENDS_${PN} = "automotive-message-broker"
+
+RPROVIDES_${PN} = "ambdbusaccess"
+
+inherit qmake5
+
+do_install () {
+        mkdir -p ${D}/usr/lib/qt5/qml/Automotive/
+        cp ambdbusaccess ${D}/usr/lib/qt5/qml/Automotive/
+}
+
+FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"
+FILES_${PN}-dbg += "${libdir}/qt5/qml/Automotive/.debug"
+