Convert to new override syntax
[AGL/meta-agl-demo.git] / recipes-apis / agl-service-cloudproxy / agl-service-cloudproxy_git.bb
index 588e86f..7281a59 100644 (file)
@@ -3,21 +3,21 @@ DESCRIPTION = "AGL cloud proxy service build with recipe method"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy"
 SECTION     = "apps"
 LICENSE     = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=133bb7bd14f18c4f134e819619b3f09a"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34f8c1142fd6208a8be89399cb521df9"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
 PV      = "1.0+git${SRCPV}"
-S       = "${WORKDIR}/git/"
+S       = "${WORKDIR}/git"
 
-DEPENDS = "azure-iot-sdk-c glib-2.0"
+DEPENDS = "azure-iot-sdk-c aws-iot-device-sdk-embedded-c glib-2.0 nlohmann-json"
 
 inherit cmake aglwgt pkgconfig
 
 # Azure include files
-CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
+CXXFLAGS:prepend += "-I${STAGING_INCDIR}/azureiot"
 
-RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+RDEPENDS:${PN} += "azure-iot-sdk-c azure-c-shared-utility aws-iot-device-sdk-embedded-c"
 
 BBCLASSEXTEND = "native nativesdk"