Widget packaging rework
[AGL/meta-agl-devel.git] / meta-speech-framework / meta-aac / recipes-platform / packagegroups / packagegroup-agl-voiceagent-alexa.bb
index 5f38e7e..6118dbf 100644 (file)
@@ -5,11 +5,19 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
+ALLOW_EMPTY_${PN} = "1"
+
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
-       packagegroup-agl-voiceagent-alexa \
-"
+    packagegroup-agl-voiceagent-alexa \
+    packagegroup-agl-voiceagent-alexa-test \
+    packagegroup-agl-voiceagent-alexa-devel \
+    "
+
+RDEPENDS_${PN} = " \
+    alexa-voiceagent-service \
+    "
 
-RDEPENDS_${PN} += " \
-       alexa-voiceagent-service \
-       ${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", "virtual/alexa-voiceagent-config", "",d)} \
-"
+# Empty for now, no test/dbg/coverage widgets
+RDEPENDS_${PN}-test = ""
+RDEPENDS_${PN}-devel = ""