Update various READMEs
[AGL/meta-agl.git] / meta-pipewire / recipes-multimedia / wireplumber / wireplumber_git.bb
index 6f21b25..f42b127 100644 (file)
@@ -14,9 +14,17 @@ DEPENDS = "glib-2.0 glib-2.0-native pipewire lua"
 SRC_URI = "\
     git://gitlab.freedesktop.org/pipewire/wireplumber.git;protocol=https;branch=master \
 "
-SRCREV = "4af7e2bd68c4862bb707b62edf7557df56dad10f"
+# v0.4.8
+SRCREV = "e14bb72dcc85e2130d0ea96768e5ae3b375a041e"
 
-PV = "0.4.0"
+# patches to be able to compile with lower version of meson that is available in AGL.
+SRC_URI += "\
+    file://0001-Revert-tests-add-pipewire-env-variables-when-running.patch \
+    file://0002-Revert-wp-uninstalled-build-this-script-with-the-mes.patch \
+    file://0003-spa-json-fix-va_list-APIs-for-different-architecture.patch \
+"
+
+PV = "0.4.8"
 S  = "${WORKDIR}/git"
 
 WPAPI="0.4"
@@ -38,7 +46,7 @@ PACKAGECONFIG[systemd] = "-Dsystemd=enabled -Dsystemd-system-service=true -Dsyst
 do_configure:prepend() {
     # relax meson version requirement
     # we only need 0.54 when building with -Dsystem-lua=false
-    sed "s/meson_version : '>= 0.54.0'/meson_version : '>= 0.51.0'/" ${S}/meson.build > ${S}/tmp.build
+    sed "s/meson_version : '>= 0.56.0'/meson_version : '>= 0.53.2'/" ${S}/meson.build > ${S}/tmp.build
     mv -f ${S}/tmp.build ${S}/meson.build
 }
 
@@ -53,7 +61,7 @@ FILES:${PN} = "\
     ${bindir}/wpctl \
     ${bindir}/wpexec \
     ${libdir}/wireplumber-${WPAPI}/* \
-    ${datadir}/wireplumber/* \
+    ${datadir}/wireplumber/scripts/* \
     ${systemd_system_unitdir}/* \
 "
 RPROVIDES:${PN} += "virtual/pipewire-sessionmanager"
@@ -65,6 +73,11 @@ FILES:lib${PN}-${WPAPI} = "\
 
 FILES:${PN}-config += "\
     ${sysconfdir}/wireplumber/* \
+    ${datadir}/wireplumber/*conf \
+    ${datadir}/wireplumber/common/* \
+    ${datadir}/wireplumber/main.lua.d/* \
+    ${datadir}/wireplumber/bluetooth.lua.d/* \
+    ${datadir}/wireplumber/policy.lua.d/* \
 "
 CONFFILES:${PN}-config += "\
     ${sysconfdir}/wireplumber/* \