Add recipe for blobsallad package (JTA QA requirement)
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / blobsallad / blobsallad_2006-11-14-23-57.bb
diff --git a/meta-ivi-common/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb b/meta-ivi-common/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb
new file mode 100644 (file)
index 0000000..c3d7443
--- /dev/null
@@ -0,0 +1,34 @@
+DESCRIPTION = ""
+HOMEPAGE = "http://blobsallad.se/"
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRC_URI = " \
+    http://blobsallad.se/src/blobsallad-src-${PV}.tar.gz \
+    file://0001-Makefile.patch \
+    file://0002-auto.patch \
+    file://0003-printcleanup.patch \
+    file://0004-bs_main.c.patch"
+
+SRC_URI[md5sum] = "a2e3342cbf0f3a4a9b110af2663bed36"
+SRC_URI[sha256sum] = "cd6309df1929d3e6b7bce1dbecc751849aeaafe17c01e05fd2567dc4267faaa2"
+
+DEPENDS = "cairo virtual/libsdl"
+
+S = "${WORKDIR}/blobsallad-src"
+
+do_configure () {
+       # Specify any needed configure commands here
+       :
+}
+
+do_compile () {
+       # You will almost certainly need to add additional arguments here
+       oe_runmake SDKROOT=${STAGING_DIR_HOST}
+}
+
+do_install () {
+       install -d ${D}${bindir}
+       install -m 0755 blobsallad ${D}${bindir}
+}
+