meta-html5-framework/wam: adjust how wam is started
[AGL/meta-agl-devel.git] / meta-html5-framework / recipes-wam / wam / wam_git.bb
index 3cf0081..a4012fa 100644 (file)
@@ -3,44 +3,42 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-inherit qmake5
+inherit cmake
 
-DEPENDS = "qtbase glib-2.0 jsoncpp chromium68 wayland-ivi-extension libhomescreen libwindowmanager"
+DEPENDS = "glib-2.0 jsoncpp boost chromium68 wayland-ivi-extension libhomescreen libwindowmanager"
+
+EXTRA_OECMAKE = "\
+    -DCMAKE_BUILD_TYPE=Release \
+    -DCMAKE_INSTALL_PREFIX=${prefix} \
+    -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
+    -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
 
 PR="r0"
 
 PROVIDES += "virtual/webruntime"
 RPROVIDES_${PN} += "virtual/webruntime"
 
-SRC_URI = "git://github.com/webosose/${PN}.git;branch=@2.chromium68.5.agl.flounder;protocol=https"
+SRC_URI = "\
+    git://github.com/webosose/${PN}.git;branch=@6.agl.guppy;protocol=https \
+    file://WebAppMgr@.service \
+    file://WebAppMgr.env \
+"
 S = "${WORKDIR}/git"
-SRCREV = "fe79cfcf55eff8fc6709ec4845fe6d5a3e9b9e5a"
-
-EXTRA_QMAKEVARS_PRE += "CONFIG_BUILD+=agl_service"
-EXTRA_QMAKEVARS_PRE += "PREFIX=/usr"
-EXTRA_QMAKEVARS_PRE += "PLATFORM=${@'PLATFORM_' + '${DISTRO}'.upper().replace('-', '_')}"
-EXTRA_QMAKEVARS_PRE += "CHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
-OE_QMAKE_CXXFLAGS += "-Wno-unused-variable"
+SRCREV = "8271e13578b92b192cef1d1ac6577bc3699518a4"
 
 do_install_append() {
     install -d ${D}${sysconfdir}/wam
     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
-    install -d ${D}${systemd_user_unitdir}
-    install -v -m 644 ${S}/files/launch/WebAppMgr.service ${D}${systemd_user_unitdir}/WebAppMgr.service
+    install -d ${D}${systemd_system_unitdir}
+    install -v -m 644 ${WORKDIR}/WebAppMgr@.service ${D}${systemd_system_unitdir}/WebAppMgr@.service
     install -d ${D}${sysconfdir}/default/
-    install -v -m 644 ${S}/files/launch/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
+    install -v -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
     ln -snf WebAppMgr ${D}${bindir}/web-runtime
-    install -d ${D}${sysconfdir}/systemd/user/default.target.wants
-    ln -sf ${systemd_user_unitdir}/WebAppMgr.service ${D}${sysconfdir}/systemd/user/default.target.wants
-}
-
-pkg_postinst_${PN}_append() {
-    chsmack -a "*" /usr/bin/WebAppMgr
-    chsmack -a "*" /usr/lib/libWebAppMgr.so.1.0.0
-    chsmack -a "*" /usr/lib/libWebAppMgrCore.so.1.0.0
-    chsmack -a "*" /usr/lib/webappmanager/plugins/libwebappmgr-default-plugin.so
+    install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
+    ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
 }
 
 RDEPENDS_${PN} += "wam-tinyproxy"
-FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_user_unitdir}"
+FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
 
+CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"