Update agl-service-windowmanager-2017
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-graphics / agl-service-windowmanager-2017 / agl-service-windowmanager-2017_git.bb
index addee32..dfc3797 100644 (file)
@@ -1,32 +1,23 @@
-SUMMARY     = "Window Manager binding and client library for application"
-DESCRIPTION = "Window Manager 2017 is the binding library  \
-       "
-HOMEPAGE    = ""
-S = "${WORKDIR}/git"
-SECTION = "graphics"
+SUMMARY     = "Window Manager service binding for applications"
+DESCRIPTION = "Window Manager 2017 is the service binding for controlling \
+               rendering rights. Applications request to render itself, \
+               then Window Manager checks the policy and notifies the \
+               layout to the respective applications \
+              "
+HOMEPAGE    = "https://wiki.automotivelinux.org/windowmanager"
+SECTION     = "graphics"
 LICENSE     = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
-DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
-RDEPENDS_${PN} = " \
-       "
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93 \
+                    file://LICENSE.MIT;md5=a7514fe5664902e337bd8a4443d8f348"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=master"
-SRCREV = "d5eb8b53ed088db5a25451fc7e3009d3e44ae6bd"
+DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
 
 inherit cmake aglwgt
 
-#If you would like to output log, uncomment out
-#EXTRA_OECMAKE = " -DENABLE_DEBUG_OUTPUT=ON "
-
-do_install_append() {
-    install -d ${D}${sysconfdir}/windowmanager
-    install -m 0644 ${S}/layers.json ${D}${sysconfdir}/windowmanager/
-    install -d ${D}${libdir}/pkgconfig
-    install -m 0644 ${B}/windowmanager.pc ${D}${libdir}/pkgconfig
-    install -d ${D}${includedir}
-    install -m 0644 ${S}/libwindowmanager/libwindowmanager.h ${D}${includedir}
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "1859dd4135f5d019f16a1333df318ecd1211afb9"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
 
-    install -m -0755 ${B}/libwindowmanager/libwindowmanager.so ${D}${libdir}/libwindowmanager.so.0.1
-    ln -sf libwindowmanager.so.0.1 ${D}${libdir}/libwindowmanager.so
-}
-FILES_${PN} += "${sysconfdir}/windowmanager/layers.json"
+#If you would like to output log, uncomment out
+EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "