Merge "4a-softmixer: bump revision (submodules update, less verbosity)"
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-graphics / agl-service-windowmanager-2017 / agl-service-windowmanager-2017_git.bb
index 1bafd07..50e6dd4 100644 (file)
@@ -1,19 +1,23 @@
 SUMMARY     = "Window Manager service binding for applications"
-DESCRIPTION = "Window Manager 2017 is the service binding for controlling rendering rights \
-    Applications requests to render itself, then Window Manager check policy and notify layout to respective applications \
-    "
+DESCRIPTION = "Window Manager 2017 is the service binding for controlling \
+               rendering rights. Applications request to render itself, \
+               then Window Manager checks the policy and notifies the \
+               layout to the respective applications \
+              "
 HOMEPAGE    = "https://wiki.automotivelinux.org/windowmanager"
-SECTION = "graphics"
+SECTION     = "graphics"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93 \
                     file://LICENSE.MIT;md5=a7514fe5664902e337bd8a4443d8f348"
-DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=master"
-SRCREV = "9d25a6eaeb93ab7c732b3dbca28b6fa86b15347c"
-S = "${WORKDIR}/git"
+DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
 
 inherit cmake aglwgt
 
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "a79b572a5f26d6ecdd97dff159c40bad330e1c4c"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
 #If you would like to output log, uncomment out
-#EXTRA_OECMAKE = " -DENABLE_DEBUG_OUTPUT=ON "
+EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "