agl-service-windowmanager: add weston-ready systemd dependency
[AGL/meta-agl-devel.git] / meta-hmi-framework / recipes-graphics / agl-service-windowmanager / agl-service-windowmanager_git.bb
index a7dd894..d80106c 100644 (file)
@@ -13,10 +13,24 @@ DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
 
 inherit cmake aglwgt
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH} \
+           file://weston-ready.conf \
+"
 SRCREV = "fb861c2f05e5f49f4009d0d7c91101259f904f1d"
 PV = "1.0+git${SRCPV}"
 S = "${WORKDIR}/git"
 
 #If you would like to output log, uncomment out
 EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "
+
+do_install_append() {
+    # Install systemd over-ride that adds a dependency on weston-ready
+    # to ensure that the windowmanager and its dependencies start after
+    # weston is actually initialized.
+    install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+    install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+REDEPENDS_${PN} += "weston-ready"