set LIBASOUND_THREAD_SAFE=0 for 4a
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-multimedia / agl-service-audio-4a / agl-service-audio-4a_git.bb
index 2422743..63d2bdb 100644 (file)
@@ -14,7 +14,7 @@ S  = "${WORKDIR}/git"
 
 inherit cmake aglwgt pkgconfig
 
-DEPENDS += "alsa-lib json-c systemd af-binder glib-2.0"
+DEPENDS += "alsa-lib json-c systemd af-binder glib-2.0 lua"
 
 do_aglwgt_deploy_append() {
        cat <<'EOF' >${D}/${sysconfdir}/agl-postinsts/99_4A_service_patch.sh
@@ -30,8 +30,13 @@ while ! ls $svcfile > /dev/null; do
 done
 sed -i '/\[Unit\]/ a Before=pulseaudio.service' $svcfile;
 sed -i '/\[Unit\]/ a ConditionPathExistsGlob=/dev/snd/control*' $svcfile;
+sed -i '/ExecStartPre=/ a Environment=LIBASOUND_THREAD_SAFE=0' $svcfile;
+
+sed -i -e 's|/usr/bin/afb-daemon\>|& --ldpath=/usr/libexec/agl/4a-alsa-core/lib:/usr/libexec/agl/4a-hal/lib:/usr/libexec/agl/afb-aaaa/lib:/usr/libexec/agl/smixer/lib|' $svcfile
+
+# binder name matters: it must match "afbd-4a-*" => the config file (controller json file) that will be searched will be "policy-4a-*.json"
+sed -i -e 's|--name afbd-agl-\(.*\)|--name afbd-4a-\1|' $svcfile
 
-sed -i -e 's|/usr/bin/afb-daemon\>|& --ldpath=/usr/libexec/agl/afb-aaaa/lib:/usr/libexec/agl/4a-alsa-core/lib|' $svcfile
 echo "-- TMP 4A INSTALL FIX END"
 
 EOF