move 4a-hal-unicens (plugin) to gerrit
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-multimedia / 4a-hal-unicens / 4a-hal-unicens_git.bb
index 84ee604..fa24eba 100644 (file)
@@ -4,15 +4,26 @@ HOMEPAGE    = "https://git.automotivelinux.org/src/4a-hal-unicens/"
 SECTION     = "apps"
 
 LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e385f6075dcdf3ad6ff0056fca58a129"
+
+DEPENDS += "lua"
 
 SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-unicens;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "6d4cbab774c0fa632ccdf4add35b87d0828ac765"
+SRCREV = "9228c9da5b85f0fdd6b01f0309e57b846618be63"
+
 
 PV = "0.1+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 inherit afb-system-cmake
 
-FILES_${PN}-dev += "${INSTALL_PREFIX}/afb-aaaa/htdocs"
-FILES_${PN} += "${INSTALL_PREFIX}/afb-aaaa"
+do_install_append () {
+    # installation folder for this plugin is '4a-hal'
+    # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
+    PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
+
+    # transition: provided by separate package
+    rm -rf $PKGDIR/etc
+}
+
+