Cleanup deprecated 4A configuration files
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-multimedia / 4a-hal-generic / 4a-hal-generic_git.bb
index 0bff58a..97dae65 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
 SRC_URI = "gitsm://github.com/iotbzh/4a-hal-generic;protocol=https;branch=${AGL_BRANCH}"
 #SRCREV = "${AGL_APP_REVISION}"
-SRCREV = "90cae7bdb9487225d11e8daeea0202a1db5605bb"
+SRCREV = "08b6e7144a87f60b86c8988c33a44dbd61026a8f"
 
 DEPENDS += "lua"
 
@@ -36,16 +36,16 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 ### TODO: this list should be completed for more machines
 
 do_install_append () {
-       # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
-       PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
-
-       # move all config files to a 'available' dir
-       mv $PKGDIR/etc $PKGDIR/etc.available
-
-       # then install only required hals files in the etc folder
-       mkdir -p $PKGDIR/etc
-       for x in ${4A_HAL_LIST}; do
-               hal=hal-4a-$x.json
-               mv -v $PKGDIR/etc.available/${hal}.json $PKGDIR/etc/
-       done
+    # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
+    PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
+
+    # move all config files to a 'available' dir
+    mv $PKGDIR/etc $PKGDIR/etc.available
+
+    # then install only required hals files in the etc folder
+    mkdir -p $PKGDIR/etc
+    for x in ${4A_HAL_LIST}; do
+        hal=hal-4a-$x.json
+        mv -v $PKGDIR/etc.available/${hal} $PKGDIR/etc/
+    done
 }