4a: Add Bluetooth in 4a
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-multimedia / 4a-hal-generic / 4a-hal-generic_git.bb
index 7cc5ba4..5402c8d 100644 (file)
@@ -7,8 +7,7 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
 SRC_URI = "gitsm://github.com/iotbzh/4a-hal-generic;protocol=https;branch=${AGL_BRANCH}"
-#SRCREV = "${AGL_APP_REVISION}"
-SRCREV = "08b6e7144a87f60b86c8988c33a44dbd61026a8f"
+SRCREV = "9663aa7eb3c17eab8a91172d055f919f8acb61bf"
 
 DEPENDS += "lua"
 
@@ -33,19 +32,23 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 4A_HAL_LIST_h3ulcb          ?= "rcar-m3 rcar-m3kf"
 4A_HAL_LIST_intel-corei7-64 ?= "intel-minnow"
 4A_HAL_LIST_qemux86-64      ?= "intel-qemu"
+
+# Due to bug SPEC-1610, default hal for RPI3 is not active yet
+# 4A_HAL_LIST_raspberrypi3    ?= "raspberry-pi-3"
+
 ### TODO: this list should be completed for more machines
 
 do_install_append () {
-       # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
-       PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
-
-       # move all config files to a 'available' dir
-       mv $PKGDIR/etc $PKGDIR/etc.available
-
-       # then install only required hals files in the etc folder
-       mkdir -p $PKGDIR/etc
-       for x in ${4A_HAL_LIST}; do
-               hal=hal-4a-$x.json
-               mv -v $PKGDIR/etc.available/${hal}.json $PKGDIR/etc/
-       done
+    # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
+    PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
+
+    # move all config files to a 'available' dir
+    mv $PKGDIR/etc $PKGDIR/etc.available
+
+    # then install only required hals files in the etc folder
+    mkdir -p $PKGDIR/etc
+    for x in ${4A_HAL_LIST}; do
+        hal=hal-4a-$x.json
+        mv -v $PKGDIR/etc.available/${hal} $PKGDIR/etc/
+    done
 }